Results 1 to 8 of 8
  1. #1
    Ausfish Bronze Member
    Join Date
    Aug 2007
    Post Thanks / Like
    Classifieds
    0

    Evinrude electrical fault with Power pack??

    Hi all,
    I have a 1990 140 evinrude V4 with suspected (??) electrical fault and was looking for some opinions to see if I am on the right track.

    The problem....
    I was out in the Bay, all running well, but started having problems where under load the engine lost significant amount of power. Initially the odd blip at 3/4 throttle, until it got to the point where it ran at about 30-50% power only at WOT. Then stayed like that for the trip home (fortunately just got it up on plane, or it was a long day).
    Engine had no misses, was not spluttering, just down on power.
    Was most noticeable under load, and you couldn't really tell at idle.
    I thought it was fuel related (starving to a carby or bank of carbies) and was a blockage in the line or jets. After cleaning and checking all pretty sure this is not the issue, and believe it is electrical.

    When running on the trailer, removal of plug leads to port side shows reduced revs with one lead off, further reduced with 2 leads off, to the point that it stalls within a few seconds.

    If I put all plug leads back, restart and then remove starboard leads only, there is no change to the idle at all, except a very very minor glitch in the revs as the leads are plugged back on and the spark kicks back in. (Seems to be spark, but very weak).

    All plugs were recently new, and all still have spark. All gaps checked and ok. Also tried with older plugs work fine for no change.
    I ohms tested all 4 ignition coils, they are ok and as per tolerance in manuals. I also swapped them between starboard/port cylinders for no change. Also swapped all plug leads around, no change. I will check plug leads tonight in the dark to be sure there is no short in them, but am pretty sure all is ok.

    So I am concluding the problem may be at the Power Pack ignition module. Mainly as the issue appears to occur only under load (there is spark at idle but I assume weak). It is also consistent to both starboard cylinders, which appear to be fed from the same half of the power pack.


    So the question..... Does anybody with experience on this era of motor know if that sounds like a logical conclusion? Are power packs known to partly fail on a bank of cylinders, or perhaps fail only under load (I have read posts of total failure or not at all)?
    Any other ideas?

    I am trying to avoid replacing the power pack unless I am fairly sure it is the problem.

    Thanks in advance for any comments/suggestions.
    Darren.

  • #2
    Ausfish Platinum Member Jabba_'s Avatar
    Join Date
    Nov 2007
    Location
    Labrador
    Post Thanks / Like
    Classifieds
    0

    Re: Evinrude electrical fault with Power pack??

    Would be too hard to take it into a mechanic to get it diagnose, rather then guessing what the fault might be... There may be another under laying problem that caused the left bank to fail....

  • #3
    Banned
    Join Date
    Dec 2006
    Location
    Thornlands
    Post Thanks / Like
    Classifieds
    0

    Re: Evinrude electrical fault with Power pack??

    I had a similar issue with my 115 Johnson. The guy who diagnosed it had a powerpack that had a fault at a certain revs. He put it in and tested it and it failed at those revs. Then put mine back in and tested and failing at way lower revs. New power pack all good!!

  • #4
    Ausfish Bronze Member
    Join Date
    Aug 2007
    Post Thanks / Like
    Thread Starter
    Classifieds
    0

    Re: Evinrude electrical fault with Power pack??

    Hi guys,
    Thanks for the replies.

    Jabba,
    Was trying to avoid the mechanic, as my experience is many of them just replace parts until it is fixed, and rarely can tell you the problem without doing the same process I have. There advantage is they may have a power pack to bolt on and try, but I don't.
    However if needed I will talk to some mechanics and see if any are able to diagnose/test the power pack.

    Lump,
    That helps a lot. Shows the PP can break down at certain revs only, which all other info suggested otherwise. Appears most likely to be the problem.

    Any others with experience out there?

    Cheers.

  • #5
    Ausfish Addict Jarrah Jack's Avatar
    Join Date
    Feb 2009
    Location
    Mornington Peninsula
    Post Thanks / Like
    Classifieds
    0

    Re: Evinrude electrical fault with Power pack??

    Had a few power packs go and the trouble is that they are expensive things so you want to be certain that they are the cause of the problem. You seem to be on the right track with eliminateing other possible causes leaving the PP as the culprit. There may be other tests you can do as well.

    When buying a replacement do the ring around and look at after market from the US and here, the wreckers may have something as well. (which is where I got my last one from)

  • #6
    Ausfish Addict Noelm's Avatar
    Join Date
    Mar 2006
    Location
    Shellharbour
    Post Thanks / Like
    Classifieds
    0

    Re: Evinrude electrical fault with Power pack??

    I think your motor has the power pack that bolts on top of the motor correct? if so they do cause a lot of funny faults, but they are not cheap to buy, so the choice is yours, buy one and hope, or take it to a "man" and pay for his services.

  • #7
    Ausfish Bronze Member
    Join Date
    Aug 2007
    Post Thanks / Like
    Thread Starter
    Classifieds
    0

    Re: Evinrude electrical fault with Power pack??

    Noelm,
    Thats the one at the top.
    From the responses I have, I am pretty sure it is the culprit. My brother is an auto electrician (no marine experience/understanding) and he agrees it does not appear to be anything else.

    I might see if I can locate a second hand one. I also have a contact at a marine store that may be able to loan or track down a second hand one to try.

    Thanks all for the comments.
    Darren

  • #8
    Ausfish Addict Noelm's Avatar
    Join Date
    Mar 2006
    Location
    Shellharbour
    Post Thanks / Like
    Classifieds
    0

    Re: Evinrude electrical fault with Power pack??

    best buy a new one, second hand electrical bits are dodgey at best I reckon, I do believe there is still non genuine ones available for a much cheaper price. The power pack is a bit of a lottery, it may well be a dud, but it also maybe something else, impossible to know without proper testing or replacement.

  • Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •