Page 2 of 3 FirstFirst 123 LastLast
Results 16 to 30 of 31
  1. #16

    Re: Motorguide Xi5 trouble shooting - drops from anchor mode into standby mode

    still at a loss as to why the motor guide wont spot lock. seems to work in the work shop but as soon as it is on the water the GSP will drop out ever time the anchor mode is used.

    all other functions seem to work fine but the GPS anchor mode is just a piece of shit, not ####en happy

    anyone else having anchor mode issues with there motorguide.

    BigE

  2. #17
    Ausfish Addict disorderly's Avatar
    Join Date
    Sep 2006
    Location
    In the Jungle

    Re: Motorguide Xi5 trouble shooting - drops from anchor mode into standby mode

    Quote Originally Posted by BigE View Post
    still at a loss as to why the motor guide wont spot lock. seems to work in the work shop but as soon as it is on the water the GSP will drop out ever time the anchor mode is used.

    all other functions seem to work fine but the GPS anchor mode is just a piece of shit, not ####en happy

    anyone else having anchor mode issues with there motorguide.

    BigE
    Hi mate ..I wonder how they will test it I the workshop ...last trip it only dropped out 2-3 times over 2 days but the trip before it did it regularly...I have used a 3 prong plug , cable and circuit breaker they recommended and sold me at the Mercury dealership....

  3. #18

    Re: Motorguide Xi5 trouble shooting - drops from anchor mode into standby mode

    Starting to sound like a refund or replacement due.

  4. #19

    Re: Motorguide Xi5 trouble shooting - drops from anchor mode into standby mode

    Yep , they did the magic dongle trick to update the software ... no change , took it off the boat back to the shop for 2 weeks to replace the mother board ,still drops out. technician can't replicate the fault in the workshop recons it's the install ?? pulled all the wiring out started from scratch new wires to link the batteries without any Andersen plugs this time , new wiring direct to the MG unit by the shortest possible route only join in the whole system is one Andersen plug where the MG unit harness connects to the battery harness. refit the unit , same result. at this point i'm out of ideas.

    i far as i can tell the GPS will lose it's fix when ever there is load on the MG to hold position , which pretty much makes it useless.

    BigE

  5. #20

    Re: Motorguide Xi5 trouble shooting - drops from anchor mode into standby mode

    Quote Originally Posted by disorderly View Post
    Hi mate ..I wonder how they will test it I the workshop ...last trip it only dropped out 2-3 times over 2 days but the trip before it did it regularly...I have used a 3 prong plug , cable and circuit breaker they recommended and sold me at the Mercury dealership....
    I removed the unit from the boat and they bolted it to a work bench on wheels, they used the anchor function and then moved the workbench away from the anchor spot and the unit responded by turning toward the anchor spot an engaging the propeller.

    big E

  6. #21
    Ausfish Addict disorderly's Avatar
    Join Date
    Sep 2006
    Location
    In the Jungle

    Re: Motorguide Xi5 trouble shooting - drops from anchor mode into standby mode

    I was talking to the Mercury dealer yesterday who sells a lot of MG trolling motors.

    He described the issue as they had experienced a run of motors with the problem which might have been from the same batch.....

    Something about the control board allowing the voltage too drop low enough that it momentarily dropped out the GPS/anchor mode but would then start working straight away once reset....and so on till next time...

    He told me to bring the motor in and they will just replace the control board and it would be good to go...

  7. #22

    Re: Motorguide Xi5 trouble shooting - drops from anchor mode into standby mode

    Quote Originally Posted by disorderly View Post
    I was talking to the Mercury dealer yesterday who sells a lot of MG trolling motors.

    He described the issue as they had experienced a run of motors with the problem which might have been from the same batch.....

    Something about the control board allowing the voltage too drop low enough that it momentarily dropped out the GPS/anchor mode but would then start working straight away once reset....and so on till next time...

    He told me to bring the motor in and they will just replace the control board and it would be good to go...
    interesting ..... sounds exactly like what is occurring with mine. i notice that my power light will blink just before the it loses anchor lock.

    do you have anymore info on this? I would really like a fix to this issue.

    BigE

  8. #23
    Ausfish Addict disorderly's Avatar
    Join Date
    Sep 2006
    Location
    In the Jungle

    Re: Motorguide Xi5 trouble shooting - drops from anchor mode into standby mode

    Quote Originally Posted by BigE View Post
    interesting ..... sounds exactly like what is occurring with mine. i notice that my power light will blink just before the it loses anchor lock.

    do you have anymore info on this? I would really like a fix to this issue.

    BigE
    I'll let you know how it goes....might take it up this coming week .

  9. #24

    Re: Motorguide Xi5 trouble shooting - drops from anchor mode into standby mode

    Had any luck in resolving the issues with your MG and the anchor lock BigE?

  10. #25

    Re: Motorguide Xi5 trouble shooting - drops from anchor mode into standby mode

    Quote Originally Posted by fishing111 View Post
    Had any luck in resolving the issues with your MG and the anchor lock BigE?
    Got a new unit ...under warranty....... just done the fit up but have not put it in the water yet.
    will post again when i give it a run.


    BigE

  11. #26

    Re: Motorguide Xi5 trouble shooting - drops from anchor mode into standby mode

    I hope you have it sorted with the new unit, a lot of mucking and stuffing around though to get it by the sounds of it. I'm sort of amazed they don't check the units before sale (factory) to make sure everything is ok, but obviously there would be a reason for why they can't.

  12. #27
    Ausfish Addict disorderly's Avatar
    Join Date
    Sep 2006
    Location
    In the Jungle

    Re: Motorguide Xi5 trouble shooting - drops from anchor mode into standby mode

    Quote Originally Posted by BigE View Post
    Got a new unit ...under warranty....... just done the fit up but have not put it in the water yet.
    will post again when i give it a run.


    BigE
    Lucky you.....I took my unit in on Monday and had a new control board fitted.....

    I am assured this will fix any issues....whilst unhooking it I found some corrosion on the plug and the plug had partially melted....last trip the motor had stopped ..light gone out...

    They weren't sure what caused this..

    I don't really know if the issues have been fixed as I took it out for a spin on Tuesday and somehow lost the propeller...I don't know whether they remove it for testing in the workshop but I really should have checked it when I refitted the unit...I also don't know why there is not a split pin or something on the prop shaft...

    I am not liking my Motorguide ATM....

  13. #28

    Re: Motorguide Xi5 trouble shooting - drops from anchor mode into standby mode

    You have certainly had a bad run with you MG. I wondered when you would lose a prop as I have just lost one and most of my mates have also lost one or two as well. The problem is that when you add the anode and washer there is only about two or three threads on the locking nut. It barely bites the nylock insert. To me it is a design fault they just have not made the prop shaft and threaded section long enough.

    I have not had the spot lock issue but my fishing mate has on his. A new GPS control unit fixes it. The other issue we are experiencing is bubbling of the powder coat on the front housing. The dealer said they will fix under warranty so I am waiting for parts to come.

    Other than the above it has been brilliant!

  14. #29

    Re: Motorguide Xi5 trouble shooting - drops from anchor mode into standby mode

    Quote Originally Posted by Red October View Post
    You have certainly had a bad run with you MG. I wondered when you would lose a prop as I have just lost one and most of my mates have also lost one or two as well. The problem is that when you add the anode and washer there is only about two or three threads on the locking nut. It barely bites the nylock insert. To me it is a design fault they just have not made the prop shaft and threaded section long enough.

    I have not had the spot lock issue but my fishing mate has on his. A new GPS control unit fixes it. The other issue we are experiencing is bubbling of the powder coat on the front housing. The dealer said they will fix under warranty so I am waiting for parts to come.

    Other than the above it has been brilliant!
    When i put the prop on mine i realised the thread isnt as long as i would like. I think ill take it back off and add some loctite.

    Sent from my SM-A205YN using Tapatalk

  15. #30

    Re: Motorguide Xi5 trouble shooting - drops from anchor mode into standby mode

    Yep I loktite mine now. I have also ground away a few mils off the prop where the anode sits to give me a couple of extra threads for it to lock into.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Join us