Results 1 to 6 of 6
  1. #1

    Lowrance HDS Gen 3 sonar problems?

    Hello everyone,

    Just wondering if anyone has had a similar problem and has a fix.

    Since updating my HDS Gen 3 to the latest firmware on my last trip the sonar would just stop and it actually displayed "stopped" on the bottom of the screen. I had to go into the menu and press stop to get it going again. Not long after it would stop again. This has never happened before. I checked all the plugs and they were all connected properly. I turned the unit off then on again and still the same problem.

    Any my help would be appreciated.

    Regards,
    Nick

  2. #2

    Re: Lowrance HDS Gen 3 sonar problems?

    There was someone on facebook had issues (different though) after the latest update as well. It could be buggy. Wouldn't be the first time. Did you do a full reset after updating? Make sure you back up first.
    "I soak the worms in rum. The fish love em and the worms die happy"
    "Alcohol is not the solution to your problems...................but then again, neither is milk"

  3. #3

    Re: Lowrance HDS Gen 3 sonar problems?

    Wait a week, look out for another update. The doc will make no mention but hey presto your problem will go away. Happens with Apple all the time.


    Sent from my iPhone using Ausfish forums

  4. #4

    Re: Lowrance HDS Gen 3 sonar problems?

    Should be able to roll back

  5. #5

    Re: Lowrance HDS Gen 3 sonar problems?

    G'day
    Call lowrance support, they are very good, if it's a bug in the update they'll get it fixed pretty quickly
    Cheers
    Rod

  6. #6

    Re: Lowrance HDS Gen 3 sonar problems?

    Thanks for the replies.
    I have contacted Lowrance with the problem and waiting for them to get back to me.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Join us