Results 1 to 6 of 6

Thread: Touch screen

  1. #1

    Touch screen

    Fellas,Have a garmin 751,when I turn it on it does it thing then asks to hit agree works fine then comes up with no transducer as I am not using chirp all good so far,now when I try and open up the charts folder nothing,and all other icons are the same,yet the bottom ones all work only the top ones wont.Its like it wont recognise my touch so to speak.any advie.
    CHEERS THE JUDGE

  2. #2

    Re: Touch screen

    seems as if you just need to re-calibrate the touch screen

    Marine outfitting solutions
    www.moosemarine.com.au

  3. #3

    Re: Touch screen

    I tried that moose but it wont let me open any part of the top screen,going to get some alcohol and give the screen a god clean its as if the screen has like a film on it will give that a go and see what happens

  4. #4

    Re: Touch screen

    If nothing else works, try a system master reset. From memory on the older units at least, it's accessed by holding a finger on one of the corners after you turn it on (can't remember which corner) while the garmin logo is being displayed at boot up. This WILL delete any user information and settings so if you don't have a back up of your marks you may wish to investigate other things first - possibly a software update - anything that gives the units memory a "kick in the pants".
    "I soak the worms in rum. The fish love em and the worms die happy"
    "Alcohol is not the solution to your problems...................but then again, neither is milk"

  5. #5

    Re: Touch screen

    Quote Originally Posted by bigjudge View Post
    I tried that moose but it wont let me open any part of the top screen,going to get some alcohol and give the screen a god clean its as if the screen has like a film on it will give that a go and see what happens
    All I read "was going to get some alcohol"

    A man after my own heart. Nothing a few beers won't fix

  6. #6

    Re: Touch screen

    Quote Originally Posted by scottar View Post
    If nothing else works, try a system master reset. From memory on the older units at least, it's accessed by holding a finger on one of the corners after you turn it on (can't remember which corner) while the garmin logo is being displayed at boot up. This WILL delete any user information and settings so if you don't have a back up of your marks you may wish to investigate other things first - possibly a software update - anything that gives the units memory a "kick in the pants".
    What Scottar said, my gpsmap 70s went all funky on me about 12 moths ago so did a factory reset and started again. All fixed and thankfully i had a backup copy of gps marks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Join us