Page 1 of 2 12 LastLast
Results 1 to 15 of 18
  1. #1

    Suzuki outboard owners...

    I am looking to amswer the question.... do suzuki outboards after 2008 still hsve corosion problems. And if so whsts your experience.

    Sent from my SM-G900I using Tapatalk

  2. #2

    Re: Suzuki outboard owners...

    no problems with 2009 df60 and a 2015 df140 yet.I do check my anodes reg.though.

  3. #3
    Ausfish Silver Member Swanie1975's Avatar
    Join Date
    Sep 2010
    Location
    Gold Coast

    Re: Suzuki outboard owners...

    2010 df140, no problems at all. Still clean as under the cowl

  4. #4

    Re: Suzuki outboard owners...

    Quote Originally Posted by brett777 View Post
    I am looking to amswer the question.... do suzuki outboards after 2008 still hsve corosion problems. And if so whsts your experience.

    Sent from my SM-G900I using Tapatalk
    Are you specifically referring to the known design issue of dissimilar metal corrosion in the engine holder of pre-2008 Suzukis in the DF90-140 engine family?

    If so, that problem was eliminated in about 2008 by the intriduction of a new design engine holder that didnt have that steel plug any longer. Root cause eliminated.

    Beyond that issue, there are no recurring corrosion issues of a systemic or design nature that i am aware of. At least, no more so than any other outboard motor make, where normal recommended maintenance has been completed.

    As has already been noted above, servicing and replacement of internal engine anodes is required and is listed in the maintenance schedule. Some people seem to ignore that job, and do so at their peril.

    if there is some other "corrosion issue" or rumour that you have heardabout and are now talking about, come out and say what it is, and people can respond.
    Note to self: Don't argue with an idiot. They will only bring you down to their level and beat you with experience....

  5. #5

    Re: Suzuki outboard owners...

    I think its clear what im asking and why im asking.

    Sent from my SM-G900I using Tapatalk

  6. #6

    Re: Suzuki outboard owners...

    When I read your OP I was thinking, "I wonder if he is talking about the engine holder issue or corrosion in general"?

  7. #7

    Re: Suzuki outboard owners...

    In general

    Sent from my SM-G900I using Tapatalk

  8. #8

    Re: Suzuki outboard owners...

    just a update on my df140.picked it up at Cleveland Zuk. Good price ,no hassles,goes like a dream. I think most 4strokes are good now.Dont own a etec so wont comment,only to say I see 140s on a few Bonitos and the owners are happy.
    Any outboard will be ok now with a bit of TLC>
    JMHO.

  9. #9

    Re: Suzuki outboard owners...

    Im buying mine from there but i want my facts on the extent of the corosion issues with suzi

    Sent from my SM-G900I using Tapatalk

  10. #10

    Re: Suzuki outboard owners...

    ok, I can only go on mine,no corrosion at all on both motors.They get flushed after use and serviced when I remember

  11. #11

    Re: Suzuki outboard owners...

    I think in general with Suzuki's and corrosion the stories are related the their earlier model 2 strokes. I have spoken to a Suzuki dealer and even he admitted that the earlier one's were pretty bad.
    Most modern motors have very good corrosion protection IMO.
    Remember to always log on before heading offshore.

  12. #12

    Re: Suzuki outboard owners...

    There are no fundamental general "corrosion issues" with Suzuki outboards post 2008 of any significance.
    Note to self: Don't argue with an idiot. They will only bring you down to their level and beat you with experience....

  13. #13

    Re: Suzuki outboard owners...

    I have heard of one that had the sump corrode/rust (not sure on the metal involved) out, dumped it's oil and seized but that may well be an isolated incident and have seen one with a few hours on it that had the lower cowlings off that didn't look flash - but - that said - It is my opinion that pretty much any modern day motor that has extended lower cowlings is going to have paint issues in this area. I have seen Yamahas and Zukes that looked similar and my own E-Tec does not have the slightest bit of paint left on the upper portion of the midsection that is covered by the lower pans. There is no corrosion (not last I looked anyway) but the paint has come away. The cause - my best guess is a combination of not being able to wash properly and salt being held against the surface by the noise insulation combined with exhausts that run hotter due to engines running leaner. Paint quality of modern paints could also be a factor.
    "I soak the worms in rum. The fish love em and the worms die happy"
    "Alcohol is not the solution to your problems...................but then again, neither is milk"

  14. #14

    Re: Suzuki outboard owners...

    My 08 50hp is still going great. No corrosion issues yet.
    Democracy: Simply a system that allows the 51% to steal from the other 49%.

  15. #15

    Re: Suzuki outboard owners...

    Quote Originally Posted by brett777 View Post
    I think its clear what im asking and why im asking.

    Sent from my SM-G900I using Tapatalk
    Gees, that's a bit tough, you know what you mean, but text often gets confused, my response...as per Moonlighter!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Join us